Chia SG Node issues
Incident Report for Flexpool.io
Resolved
This incident has been resolved.
Posted Sep 02, 2021 - 18:25 UTC
Investigating
We are currently investigating this issue.
Posted Sep 02, 2021 - 18:19 UTC
This incident affected: Chia (Singapore (xch-sg.flexpool.io)).