Website issues - Mining is not affected
Incident Report for Flexpool.io
Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 00:40 UTC
Investigating
We are currently investigating this issue.
Posted Apr 12, 2022 - 00:31 UTC
This incident affected: Website and API.