Chia (US-East Region) Stats Issues; Rerouted to XCH-US-West
Incident Report for Flexpool.io
Resolved
This incident was resolved. We apologize for any inconvenience caused.
Posted Jun 24, 2022 - 15:12 UTC
Investigating
We are currently investigating this issue.
Posted Jun 24, 2022 - 15:04 UTC
This incident affected: Chia (United States [East] (xch-us-east.flexpool.io)).