ETH Hong Kong DDoS Attack ongoing (Stale rate may be high)
Incident Report for Flexpool.io
Resolved
This incident has been resolved.
Posted Dec 12, 2021 - 22:01 UTC
Monitoring
The DDoS attack has stopped, and the stale rate has returned to normal level.

This could be the end of the today's DDoS attack, and as well as the pause in between them, so we will keep this incident open.

We also want to note that we are currently working hard on getting new HKE servers with better latency and advanced DDoS protection to mitigate this. We apologize for any inconvenience caused.
Posted Dec 12, 2021 - 15:24 UTC
Update
We continue being attacked, with the incoming traffic surges that sometimes are even reaching 1 Tbps (1,000 Gbps). We suspect that we are currently the target of the China's Great Cannon - a CCP's DDoS tool that is turning regular internet users into malicious attacking zombie-servers.
Posted Dec 12, 2021 - 14:35 UTC
Update
Please ensure that you are using HKE domain name (eth-hke.flexpool.io or hke.fpmirror.com) to connect to the HKE region, not a specific IP addresses. This is required in order to be sure that your worker will reach the right servers in events like this.

Please note that at Flexpool, we are strictly against of using individual IP addresses as they are subject to change without any prior notice.
Posted Dec 12, 2021 - 06:34 UTC
Identified
Our HKE proxy servers are being DoS-attacked. Stale rate may go up as new workers are pointed to DDoS-resistant endpoints.
Posted Dec 12, 2021 - 06:30 UTC
This incident affected: Ethereum (Hong Kong (eth-hk.flexpool.io/eth-hke.flexpool.io)).