Elevated stale rate on ETH-DE
Incident Report for Flexpool.io
Resolved
This incident has been resolved.

We apologize for any inconvenience caused.
Posted Mar 26, 2022 - 06:02 UTC
Investigating
We are currently investigating this issue.
Posted Mar 26, 2022 - 05:57 UTC
This incident affected: Ethereum (Germany (eth-de.flexpool.io)).